Jump to content


Xr3i efi running problem


7 replies to this topic

#1 Streetsleeper

Streetsleeper

    Newbie

  • Members
  • 4 posts

Posted 03 March 2011 - 10:57 AM

Can anyone help??? My mk4 xr3i efi, Car starts and runs if i press accellerator engine loses revs and dies but if i take my foot off it runs ok again. Smells a bit rich, had new petrol pump fitted 2 years ago but only done about 500 miles since. Changed fuel filter, block sender. Could it be overfueling? Coil pack?

Thankyou
Vinnie :D

#2 vinnyvangough

vinnyvangough

    Ford Club Admin

  • Administrators
  • 13,861 posts
  • LocationHolsworthy, Devon
  • Drives:RS2000 & Mk2

Posted 03 March 2011 - 12:10 PM

Hi and welcome to the club.

First thing i would do is take everything apart one by one, starting with the air supply side, then the fuel supply side, and clean it all.
If it hasn't done many miles it may just be bunged up and need a clean.

#3 K_G_T

K_G_T

    Advanced Member

  • Members
  • 9,379 posts

Posted 03 March 2011 - 01:28 PM

welcome aboard  FEC :D

MK4 XR3i efi  :D :D is she full 90 spec ?? - miss my ole lass

is it a late G reg or H reg 1.6 efi ? then will have auto chock - is common idle control and choke to stick - causing the start rev problem, my ole lass specially in winter months if i had done a trip abroad and been sat several weeks do the exact same thing - strip clean the idle control and choke lubricate - fix back on lub again and should cure it.

because she been sat so long and newish pump when you turn ignition key you should hear the pump inside petrol tank, should be a strong sound as it pressure primes the system if its a week sound hardly heard pump could just slack with lack of use or electrical connects rusted with been sat.

otherwise like vinny said go through the whole air /fuel systems strip and clean them out.

get some pics up in members car section :D :D

#4 Streetsleeper

Streetsleeper

    Newbie

  • Members
  • 4 posts

Posted 03 March 2011 - 01:40 PM

Many thanks for advice..... It is a late G full 90 spec with rs kit and wheels, Uprated stage 3 head, ported and polished and kent road race cam, lightened fly wheel. Recent spray job sits low. Lovely car to be honest just needs turbo puttin on. Mainly dry stored and never had single weld!!! I'll put some pics on this evening... Thanks again...:):)

#5 K_G_T

K_G_T

    Advanced Member

  • Members
  • 9,379 posts

Posted 03 March 2011 - 03:08 PM

Quote

Many thanks for advice..... It is a late G full 90 spec with rs kit and wheels, Uprated stage 3 head, ported and polished and kent road race cam, lightened fly wheel. Recent spray job sits low. Lovely car to be honest just needs turbo puttin on. Mainly dry stored and never had single weld!!! I'll put some pics on this evening... Thanks again...:):)


YOU  BARSTEWARD I HATE YOU  LOL :D :p

take me hat off to you mate for having her and looking after her - last of the old skool before the emission and electronic crap came in :rolleyes:

G reg mmm you could be lucky as some of the early EFi still had the fuel pump on outside of tank but then they changed upgraded for some reason Ford decided the last ones to fit the fuel pump in the tank and can be a git of a job lol

if you lift the backseat fold it down in footwell you will see the fuel pump wiring goes through a gromet which can painly pull up to see top of fuel sender unit shine torch in see if pump and fuel gauge wire connections are ok.

#6 ob1marty

ob1marty

    Advanced Member

  • Members
  • 1,600 posts
  • Locationwarrington cheshire
  • Drives:escort mk3

Posted 03 March 2011 - 06:45 PM

id be tempted to say throttle position switch if it has one

#7 Streetsleeper

Streetsleeper

    Newbie

  • Members
  • 4 posts

Posted 03 March 2011 - 09:35 PM

Xr efi

Yes i am a lucky barsteward!!! lol. It is my pride and joy..... The fuel pump is in the tank but nothing under back seat! Why did they do that???????? Also delocked and debadged (forgot to say). Its a great example to be honest. Trying to download pics now but not letting me for some reason..... I will figure it...:):cool::D:p

#8 Streetsleeper

Streetsleeper

    Newbie

  • Members
  • 4 posts

Posted 03 March 2011 - 10:03 PM

XR3I EFI/RS

I have managed to upload a few pics to my album, so happy viewing......:cool:



Reply to this topic