Jump to content


Been and got another!


15 replies to this topic

#1 SmurfsterST

SmurfsterST

    Advanced Member

  • Members
  • 916 posts
  • Drives:Escort GTi

Posted 18 December 2015 - 09:53 PM

Another ST TDCi came in at work so I just had to have it!!! Lol. 85k 75% service history, good clutch flywheel few bits done. And the bonus is I swapped the Mrs astra for it. :-) happy days.

Attached Files



#2 heavyrightfut

heavyrightfut

    Grim Reaper for Escorts

  • Administrators
  • 10,257 posts
  • LocationBarnsley, South Yorkshire
  • Drives:Focus RS

Posted 20 December 2015 - 01:58 PM

nice that John

#3 SmurfsterST

SmurfsterST

    Advanced Member

  • Members
  • 916 posts
  • Drives:Escort GTi

Posted 29 December 2015 - 04:38 PM

Thanks bud. Thought it would look nice on the drive. :-)

#4 heavyrightfut

heavyrightfut

    Grim Reaper for Escorts

  • Administrators
  • 10,257 posts
  • LocationBarnsley, South Yorkshire
  • Drives:Focus RS

Posted 29 December 2015 - 05:58 PM

Have you still got the Escort?

#5 SmurfsterST

SmurfsterST

    Advanced Member

  • Members
  • 916 posts
  • Drives:Escort GTi

Posted 29 December 2015 - 07:24 PM

Yeah, the engine is out, haven't got round to fitting a new one yet, but it's something to keep me busy this summer. :-)

#6 heavyrightfut

heavyrightfut

    Grim Reaper for Escorts

  • Administrators
  • 10,257 posts
  • LocationBarnsley, South Yorkshire
  • Drives:Focus RS

Posted 06 January 2016 - 07:12 PM

View PostSmurfsterST, on 29 December 2015 - 07:24 PM, said:

Yeah, the engine is out, haven't got round to fitting a new one yet, but it's something to keep me busy this summer. :-)

Glad you've still got it

#7 SmurfsterST

SmurfsterST

    Advanced Member

  • Members
  • 916 posts
  • Drives:Escort GTi

Posted 28 February 2016 - 09:18 AM

Well had an eventful week with the grey beast, been sorting a few niggles, strut top, arb bushes, to solve a clunk. Then the alternator packed up, had a nice word with the sales manager and git it paid for, brilliant I thought, however had a starting fault, only when warm, cold start was 100% fine. Thought it was dreaded fuel system woes, but after a bit of head scratching, and lots of tea, found the new alternator was fubarred. Replaced it and all is well!!! I couldn't believe an alternator was causing a fuel issue!!! But it did!!. Happy murph!!!

#8 heavyrightfut

heavyrightfut

    Grim Reaper for Escorts

  • Administrators
  • 10,257 posts
  • LocationBarnsley, South Yorkshire
  • Drives:Focus RS

Posted 28 February 2016 - 11:14 AM

Thats a strange one

#9 Paddy gti

Paddy gti

    Its a Ford Thing

  • Administrators
  • 890 posts
  • LocationPontefract
  • Drives:Escort Gti

Posted 29 February 2016 - 08:30 AM

View PostSmurfsterST, on 28 February 2016 - 09:18 AM, said:

Well had an eventful week with the grey beast, been sorting a few niggles, strut top, arb bushes, to solve a clunk. Then the alternator packed up, had a nice word with the sales manager and git it paid for, brilliant I thought, however had a starting fault, only when warm, cold start was 100% fine. Thought it was dreaded fuel system woes, but after a bit of head scratching, and lots of tea, found the new alternator was fubarred. Replaced it and all is well!!! I couldn't believe an alternator was causing a fuel issue!!! But it did!!. Happy murph!!!

sounds like a typical mondeo to me .. rear wheel bearing would probably go because the brake fluid reservoir cap isnt done tight enough or rear drop links wear out because theres not enough engine oil .. iv found theres no rhyme or reason to them just random problems

#10 SmurfsterST

SmurfsterST

    Advanced Member

  • Members
  • 916 posts
  • Drives:Escort GTi

Posted 29 February 2016 - 09:24 PM

Lol, they can be temperamental, lol, still all's well that ends well. On the look out for 2 St alloys now, so they both have full size spare wheels.

#11 SmurfsterST

SmurfsterST

    Advanced Member

  • Members
  • 916 posts
  • Drives:Escort GTi

Posted 29 February 2016 - 09:27 PM

Yeah, it had me scratching my head, had ids on it watching all the sensors and couldn't see anything out of place, just the smart charge output looking dodgy, so went with it, checked it since and the output is spot on now.

#12 heavyrightfut

heavyrightfut

    Grim Reaper for Escorts

  • Administrators
  • 10,257 posts
  • LocationBarnsley, South Yorkshire
  • Drives:Focus RS

Posted 29 February 2016 - 11:19 PM

Glad its sorted for you John

#13 SmurfsterST

SmurfsterST

    Advanced Member

  • Members
  • 916 posts
  • Drives:Escort GTi

Posted 01 March 2016 - 08:20 PM

How's tricks at your end Wayne? What's the plan for show season?

#14 heavyrightfut

heavyrightfut

    Grim Reaper for Escorts

  • Administrators
  • 10,257 posts
  • LocationBarnsley, South Yorkshire
  • Drives:Focus RS

Posted 02 March 2016 - 12:01 AM

View PostSmurfsterST, on 01 March 2016 - 08:20 PM, said:

How's tricks at your end Wayne? What's the plan for show season?

As many shows as possible

#15 SmurfsterST

SmurfsterST

    Advanced Member

  • Members
  • 916 posts
  • Drives:Escort GTi

Posted 02 March 2016 - 09:19 PM

View Postheavyrightfut, on 02 March 2016 - 12:01 AM, said:



As many shows as possible

Sounds like a fair plan. :-)

#16 Kallapser

Kallapser

    Newbie

  • Members
  • 2 posts
  • Drives:88

Posted 10 May 2017 - 03:04 PM

How does the fuel look? Mine was setting for about 3 years. and when I got it home I dropped the gas tank, it had varnish in it. Lots of it.



Reply to this topic